Monday, May 23, 2011

Flex SDK 4 to 4.5 and ArcGIS Viewer for Flex

It is possible to use Flex SDK 4.5 in Flash Builder 4.0.1


Upgrading ArcGIS Viewer for Flex 2.3.1 to Flex SDK 4.5 produced the following errors:

1.Required skin state missing errors:


normalWithPrompt,  disabledWithPrompt

Solution:  Insert this right before the line with the problem:
[States("normalWithPrompt",  "disabledWithPrompt")]

Reference: http://forums.adobe.com/message/2574211


2. Minimized widget with large canvas

Solution here:
http://forums.arcgis.com/threads/29750-flex-sdk-4.5-support